PDA

View Full Version : Visability Parameters and this Family



domsib
August 7th, 2013, 01:00 PM
I have created my own annotation symbol for a retractable switch and loaded it into Revits lighting switch family.

I'm struggling with this family because when I load it into my project and change to retractable switch I want to see this new symbol. But my symbol continues to show up when I select a dimmer switch or key switch or any other switch.

I guess I need to use a visability parameter so it shows only when needed but how do I do this?

There appears to be 7 visability parameters already for the 7 annotation symbols and I'd like to add mine as number 8 so it works in the same fashion.

I don't know the first thing about visability parameters yet so i'm hoping someone can help me out.

Thanks

cellophane
August 7th, 2013, 01:38 PM
Pick the object you want to adjust visibility for. In the properties palette there will be a box for Visible - to the right of that is a little box you can click (not the checkbox). Click it and add a new visibility parameter for your new part. I would then go through the types and make sure that it isn't showing up on any of the others. Then save & load into your project.

I would also recommend naming the visibility parameters something more logical than Visibility 1. Call them what they are: Switch Visibility, Outlet Visibility, Dimmer Visibility etc. Makes editing the family a lot easier.

domsib
August 7th, 2013, 02:58 PM
Cellophane. I've added a visability parameter as you said and my symbol is showing up in all the other symbols. How do I stop this now?

Also is there a way to only view one annotation at a time in the family because they are all on top of each other at the moment/

cellophane
August 7th, 2013, 03:13 PM
edit the type and turn off the new visibility. each type should only have one annotation visible (checked)

domsib
August 7th, 2013, 03:21 PM
edit the type and turn off the new visibility. each type should only have one annotation visible (checked)

Clicking the annotation and clicking edit type brings up the type properties and I only have 2 parameters in here. Leader Arrowhead and Label. None of those visability 1-8 parameters from earlier.

cellophane
August 7th, 2013, 03:37 PM
Clicking the annotation and clicking edit type brings up the type properties and I only have 2 parameters in here. Leader Arrowhead and Label. None of those visability 1-8 parameters from earlier.

edit the family type, not the annotation.

domsib
August 7th, 2013, 03:53 PM
edit the family type, not the annotation.

:thumbsup::thumbsup::thumbsup:

josephpeel
August 7th, 2013, 09:17 PM
If you have more than about 5 symbols in one family I recomend using a Label parameter instead of loads of visibility parameters. This gives a nice drop down menu and you cant accidentaly turn on two symbols at the same time.

Make a new Type parameter with Generic->Family Type->Generic annotation.
Set this parameter to the default symbol.
Place only the default symbol in the correct position.
Select the generic annotation and change the parameter Label to the Type parameter you made.

Now if you go to edit type you can choose all the generic annotations that exist in the family from a list, using just the one Symbol parameter. When adding new symbols you dont need to place them and make new visibility parameters, just load them in the family and they appear in the list.