PDA

View Full Version : Hide or Rezise Connectors in Preview



troygates
May 9th, 2012, 05:49 PM
In my quest to build an MEP library of families, I am finding that the size of the connector symbols cause the family preview to be unusable for small objects. See attached image. Has anyone come up with a trick to hide the connector or resize it so that the family preview looks like the actual object instead of a circle crosshair?

7988

Steve_Stafford
May 9th, 2012, 06:53 PM
In Revit 2013 I find that I can use Temporary Hide/Isolate > save the file and close it. The preview I get afterward respects the state of the view and doesn't show the connectors.

Edit: Just tried it in 2012 too...works.

troygates
May 9th, 2012, 09:40 PM
Got it to work in 2012 also, thanks Steve.

These seems like a bug, but a handy one all the same. I always figured that the temporary visibility settings weren't saved in the model since they are gone when you re-open the model. But appears that Revit might be storing them in memory until the model is closed so the view is saved with the temporary visibility settings intact, but then they are lost once the model is closed.

Randy_CaS
May 9th, 2012, 11:20 PM
Select one connector and type HC (hide category)

Steve_Stafford
May 9th, 2012, 11:23 PM
Select one connector and type HC (hide category)Right click - Hide In View isn't available in the family editor environment last time I checked. HH will fire up Hide Element though, part of Temporary/Hide Isolate's "toolbelt". Hide Category in Temporary/Hide Isolate is disabled when you select connectors for some reason...otherwise it would be true.

Randy_CaS
May 9th, 2012, 11:49 PM
I do not have 2013 here to test, but in 2010 I use it alot. I was surprised when typing "HC" worked since there is no underscore that would imply the feature works. Notice in the image all types of connectors are hidden, not just the type of connector selected.
7992