Results 1 to 5 of 5

Thread: Revit 2019 TTF Font Prints wrong characters

  1. #1
    New Member
    Join Date
    February 7, 2013
    Posts
    3
    Current Local Time
    12:09 PM

    Not allowed! Not allowed!

    Revit 2019 TTF Font Prints wrong characters

    My office uses a custom font for Revit, DIN in a TTF format. All users have the same fonts installed in c/windows/fonts.

    One user got a new computer and cannot print any of the DIN fonts as all characters are replaced by random gibberish . Font is installed. I actually removed all fonts, restarted the computer and created a new custom font and the same behavior persists. The attached screenshot shows the text type in revit, print output and installed font.

    Anyone have any ideas? I'm running Windows 10 with Revit 2019.Click image for larger version. 

Name:	2019-07-30 17_10_23-Window.png 
Views:	27 
Size:	66.2 KB 
ID:	37222

  2. #2
    Senior Member Alex Page's Avatar
    Join Date
    December 14, 2010
    Location
    Wellington, New Zealand
    Posts
    689
    Current Local Time
    05:09 AM

    Not allowed! Not allowed!
    Have you tested it with other printers and/or other applications? (i.e. have you tested with MS Word)

  3. #3
    New Member
    Join Date
    February 7, 2013
    Posts
    3
    Current Local Time
    12:09 PM

    Not allowed! Not allowed!
    Quote Originally Posted by Alex Page View Post
    Have you tested it with other printers and/or other applications? (i.e. have you tested with MS Word)
    Good idea to troubleshoot. I have no issues printing with the fonts in MS Word, the issue is limited to Revit 2019. Revit 2018 Works fine.

  4. #4
    Administrator Twiceroadsfool's Avatar
    Join Date
    December 7, 2010
    Location
    Dallas, TX
    Posts
    10,617
    Current Local Time
    10:09 AM

    Not allowed! Not allowed!
    What PDF plotter are you using, and have you tried another, within Revit 2019?

  5. #5
    New Member
    Join Date
    February 7, 2013
    Posts
    3
    Current Local Time
    12:09 PM

    Not allowed! Not allowed!
    Quote Originally Posted by Twiceroadsfool View Post
    What PDF plotter are you using, and have you tried another, within Revit 2019?
    That solved it! Mostly. Printing from a different PDF plotter, in this case, Microsoft Print to PDF, generates text characters that match the fonts. I reinstalled adobe and the adobe print driver, but it is still giving me the same issues - however if the work around is just to never use Adobe, I can live with that.

    Thanks for the troubleshooting advice.

Similar Threads

  1. Replies: 0
    Last Post: August 23rd, 2017, 04:15 AM
  2. Revit prints blank sheets.
    By arquimar in forum Architecture and General Revit Questions
    Replies: 2
    Last Post: July 15th, 2015, 02:29 PM
  3. Revit OpEd: Parameters with Math Characters
    By Revit OpEd in forum Blog Feeds
    Replies: 0
    Last Post: October 17th, 2014, 07:45 AM
  4. Replies: 0
    Last Post: November 27th, 2011, 11:15 PM
  5. Revit OpEd: No Math Characters in Parameter Names
    By Revit OpEd in forum Blog Feeds
    Replies: 0
    Last Post: November 2nd, 2011, 11:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •