Results 1 to 6 of 6

Thread: Paramter values of views

  1.    #1
    Senior Member chris.macko's Avatar
    Join Date
    April 12, 2011
    Location
    Chicago, IL
    Posts
    539
    Current Local Time
    09:56 PM

    Not allowed! Not allowed!

    Paramter values of views

    Click image for larger version. 

Name:	Dynamo view ID.PNG 
Views:	12 
Size:	141.4 KB 
ID:	37717
    Hi all,
    I am trying to pull a value out of a view parameter that I've added as part of a view template. This is a script that will create views based on scope boxes in the model and an assigned view template, and I want to be able to name the views based on this parameter defined in the template. Element.get parameter comes back blank. parameter.parameter by name shows the value, but it changes to null when I try to convert to a string or pull the value out. The highlighted ANNO-096 is what I'm trying to get in this case. This seems to behave this way for all custom parameters, but works fine for system ones.
    In this case I'm pulling it from the view after assigning the template, but if there's a way to pull it from the template directly earlier in the process, that would clean things up a bit.

    Thanks for any help in advance

  2.    #2
    Member kraftwerk's Avatar
    Join Date
    November 1, 2012
    Location
    St. Louis, MO
    Posts
    58
    Current Local Time
    09:56 PM

    Not allowed! Not allowed!
    If you are just trying to get the string of that parameter in this circumstance to name a new view, you already have that with the Str from Object node. Can you not use that to name the new view you are creating?

  3.    #3
    Senior Member chris.macko's Avatar
    Join Date
    April 12, 2011
    Location
    Chicago, IL
    Posts
    539
    Current Local Time
    09:56 PM

    Not allowed! Not allowed!
    That's the problem, the string from object is just returning the parameter name, not the value. the ANNO-096 part is getting lost somehow, and that's what I'm trying to get out.

  4.    #4
    Forum Addict elton williams's Avatar
    Join Date
    December 7, 2010
    Location
    Gold Coast
    Posts
    2,677
    Current Local Time
    01:56 PM

    Not allowed! Not allowed!
    Click image for larger version. 

Name:	Capture.PNG 
Views:	8 
Size:	106.7 KB 
ID:	37719

    why not just use Element.Name after the View.ApplyViewTemplate node?
    Last edited by elton williams; October 28th, 2019 at 11:01 PM. Reason: added image

  5.    #5
    Member Bjorn_K's Avatar
    Join Date
    April 8, 2011
    Location
    Rotterdam, Netherlands
    Posts
    345
    Current Local Time
    04:56 AM

    Not allowed! Not allowed!
    Is your ViewID a Type parameter?

  6.    #6
    Senior Member chris.macko's Avatar
    Join Date
    April 12, 2011
    Location
    Chicago, IL
    Posts
    539
    Current Local Time
    09:56 PM

    Not allowed! Not allowed!
    It is an instance parameter. It is only assigned to views. It's a shared parameter as well, but I tried a project parameter as well and it behaved the same.

Similar Threads

  1. Family - yes/no paramter - formula
    By BdeLeeuw in forum Architecture - Family Creation
    Replies: 5
    Last Post: January 9th, 2019, 12:25 PM
  2. Replies: 4
    Last Post: January 7th, 2019, 07:56 PM
  3. changing a curtain wall instance paramter to a type parameter?
    By jgu in forum Architecture and General Revit Questions
    Replies: 1
    Last Post: December 22nd, 2012, 03:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •